We have managed to temporarily distribute the excess load on our EPYC servers, ensuring stable performance across all affected systems. Over the next few days, we are planning to deploy a new EPYC-based server which will enable us to rebalance resources more effectively and further improve overall performance.
Posted Nov 19, 2025 - 22:11 CET
Investigating
Our internal monitoring system has detected a significant performance degradation on the nodes epyc7543-3 and epyc7543-4. We are actively investigating the root cause of this issue to restore normal operation as quickly as possible.
At this time, we are experiencing an unprecedented surge in support tickets related to this matter. Due to this high volume, we may not be able to respond individually to every ticket promptly. We kindly ask that you subscribe to the newsletter thread for this incident to receive continuous updates, rather than opening new tickets.
Thank you for your understanding and patience as we work diligently to resolve this.
Posted Nov 19, 2025 - 08:23 CET
This incident affects: maincubes FRA01 (EPYC KVM Server Cluster).